SaaS

Status page demo

API Request Timeouts

major icon Major
API icon
API
Identified icon Identified

Incident timeline

major icon Major

Identified - The team has identified that the issue is caused by server throttling, which is limiting the number of API requests that can be processed simultaneously. This is affecting all API interactions, leading to high latency and frequent timeouts.

Affected:
API icon
API
major icon Major

Investigating - Users began reporting slow API responses and timeouts when attempting to create or update tasks via third-party integrations. The engineering team is currently investigating the root cause of the issue.

Affected:
API icon
API